Plantronics + Polycom. Now together as Polycom

Voice
Business Media Phones (CCX Series)
DECT IP Phones
QSX
Strategic Partner Solutions
Interop Solutions

Polycom VVX 501

  • Customers in Skype for Business deployments should only use software releases that have been qualified by Microsoft or the maintenance releases built on a qualified release. Microsoft qualification may fall behind Polycom Generally Available dates for UC Software, hence we request customers to check whether a release has been qualified before deploying new software. For all latest Microsoft qualified Releases Visit Polycom UC Software for Skype for Business Deployments page for a list of qualified releases.

  • Due to a Security issue, we have replaced UC Software 5.7.0.11768, 5.7.1.2205, 5.7.2.1277, 5.8.0.12386 with 5.7.0.14430 Rev R, 5.7.1.3782 Rev D, 5.7.2.1765 Rev E, 5.8.0.13851 Rev J.
  • Please update your software and visit the Security Center for more details. 
  • VVX 300,310,400,410,500,600 & 1500 are not supported on UCS Releases starting 6.0.x & above.
  • VVX 250,350 & 450 are not supported on Skype for Business Online deployments 
  • Customers who wish to upgrade to UCS 6.2.0 & plan to use Polycom Better Together over Ethernet Connector (BToE) Application 4.3.0  should follow a mandatory step to first upgrade existing (BToE) Application 3.8.0 onwards  (with UCS 5.8 & 5.9 ) to (BToE) Application 4.3.0 followed by UC Software 5.8 & 5.9 upgrade to 6.2.0 to retain successful pairing.
  • Before you proceed to upgrade on older UCS & BToE releases please read EA 318 & refer to UCS 6.2 Release notes.
  • To view product specific How To videos, click here